Thursday, October 08, 2015

Installing Octave 4.0 in Ubuntu 14.04

So I already have Octave 3.8.1 in my machine, Ubuntu 14.04, with signal, control and audio package. I want to upgrade it to the newest one, Octave 4.0.0 which has GUI as default and some improvements. How to install Octave 4.0 on Trusty? Here is how, the defaults didn't works for me (actually it works but has some errors).

Octave 4.0.0 on Ubuntu 14.04 Trusty with GUI as default


  1. Add Octave/stable ppa
  2. sudo apt-add-repository ppa:octave/stable
  3. Update and upgrade
  4. sudo apt-get update
    sudo apt-get upgrade
  5. Download and install signal package from Octave-forge
  6. Download from here, and then in Octave do (within directory):
    pkg install signal-1.3.2.tar.gz
  7. Download and install control package from Octave-forge
  8. Download from here, and then in Octave do (within directory):
    pkg install control-2.8.5.tar.gz
  9. Download and install audio pakcage from Octave-forge
  10. Download from here, and then in Octave do (within directory):
    pkg install audio-1.1.4.tar.gz
  11. Install liboctave-dev
  12. sudo apt-get install liboctave-dev
  13. Configure Octave by using dpkg
  14. sudo dpkg --configure octave
  15. Upgrade it again
  16. sudo apt-get upgrade
  17. Now you are set, try to open in: Octave.
  18. octave

Update to 4.0.1

  1. Download the source
  2. Download the latest GNU Octave binary from here, choose the .tar.gz file >> 
  3. Install the Dependencies
  4. sudo apt-get install libblas-dev liblapack-dev libpcre3-dev libarpack2-dev libcurl4-gnutls-dev epstool libfftw3-dev transfig libfltk1.3-dev libfontconfig1-dev libfreetype6-dev libgl2ps-dev libglpk-dev libreadline-dev libhdf5-dev llvm-dev lpr libosmesa6-dev pstoedit portaudio19-dev libqhull-dev libqrupdate-dev libqscintilla2-dev libqt4-dev libqtcore4 libqtwebkit4 libqt4-network libqtgui4 libqt4-opengl-dev libsuitesparse-dev libxft-dev zlib1g-dev libportaudio19-dev
  5. ./Configure, Make, Make install
  6. Extract the .tar.gz file, cd to that directory and install with,
    mkdir build
    cd build
    sudo make install
The PPA Octave stable is maintained by Octave developer, once you add the ppa, you don't need to install from the source. However, there might be some delay time of the newest octave from the source to ppa.
Related Posts Plugin for WordPress, Blogger...