Sunday, February 24, 2013

How-to: Install Ubuntu SDK in Ubuntu 12.04 64Bit

  1. Install Qt 5 via Ubuntu PPA
  2. sudo add-apt-repository ppa:canonical-qt5-edgers/qt5-proper
  3. Install the Ubuntu SDK Preview
  4. sudo add-apt-repository ppa:ubuntu-sdk-team/ppa && sudo apt-get update && sudo apt-get install ubuntu-sdk notepad-qml

    If you got the problem as like the following:
    The following packages have unmet dependencies: ubuntu-sdk : Depends: ubuntu-qtcreator-qt5libs but it is not going to be installed Depends: ubuntu-qtcreator-plugins but it is not going to be installed E: Unable to correct problems, you have held broken packages.

    Try to install the android-adb-tools via this ppa
    sudo add-apt-repository ppa:phablet-team/tools
    sudo apt-get install phablet-tools android-tools-adb android-tools-fastboot

  5. If you still got like the following,

  6. E: /var/cache/apt/archives/qtchooser_0.0.1~git20121229.g8f08405-0ubuntu1~precise1~test5_amd64.deb: trying to overwrite '/usr/bin/qdbusxml2cpp', which is also in package libqt4-dev

    Then, try this one to solve the problem
    sudo dpkg --force all -i /var/cache/apt/archives/qtchooser_0.0.1~git20121229.g8f08405-0ubuntu1~precise1~test5_amd64.deb sudo apt-get -f install
  7. Get started to make Ubuntu apps like in here.

Ubuntu SDK interface via Qt Creator

Related Posts Plugin for WordPress, Blogger...